简介

 真实表格(TrueTable)
真实表格(TrueTable)For 浩辰CAD是一款基于浩辰CAD平台的软件，能够在浩辰CAD和Excel间互导表格， 能输出、更新浩辰CAD中的任意表格
  • 主要功能
    • 将CAD中的表格或文本输出到Excel
    • 将CAD中的表格或文本输出到文本文件(TXT)或CSV文件
    • 直接输出CAD中的任意表格，即使这些表格是复杂实体，
      比如：块参照，带属性的块参照，CAD自身的Table实体以及其它软件生成的表格
    • 将Excel表格导入CAD
    • 将文本文件(TXT)或CSV文件导入CAD
    • 同时将多个CAD表格输出到Excel文件
    • 可更新CAD中的任意表格，
      数据源可以是打开的Excel表格或Excel文件
    • 支持文本替换，可以对特殊字符进行转换
    • 可以精确定义CAD表格尺寸，
      包括文字高度、文字宽度系数、行高、列宽
    • 表格自动分片，并能设置各片表格的表头，表尾
    • 支持文本水平、垂直排列，共9种对齐方式
    • 支持自动换行，上、下标，文本旋转，竖直文本，多行文本
    • 具有文本自动替换功能，能使CAD中的特殊符号在Excel中正确显示，如将"%%c"替换为"Φ"
    • 支持Excel的隐藏行、列
    • 支持表格倒置，即输出、输入表格时颠倒表格顺序
    • 5种表格插入方式: 表格四个角点以及指定窗口
    • 对CAD中的文本进行统计
    • 材料表自动计算,钢结构用钢量统计
  • 系统要求
    • 浩辰CAD 2006/2007/2008
    • Excel 97 及其以后版本
  • 联系方式
    联系电话: 0512-66001687
    网站: www.truetable.com
    TrueTable讨论(OICQ群): 22061769
    OICQ: 21582110
    MSN: truetable@hotmail.com
    Email: truetable@truetable.com truetable@vip.163.com
    中国·苏州


 安装
  • 登陆TrueTable主页下载最新版本:http://www.truetable.com
  • 卸载TrueTable以前的版本，关闭CAD程序
  • 将下载包(Zip文件）解压缩，执行install.exe，按照提示即可完成安装
  • 安装成功后，TrueTable会自动加载到CAD中，并显示"TrueTable"菜单， 可以点击菜单来运行
卸载
  • 点击"开始"菜单 -> "程序"，找到"TrueTable"菜单，点击"卸载TrueTable"

    或者

    点击"开始"菜单 -> "设置" -> "控制面板" -> "添加/删除程序"，找到"TrueTable"程序，点击"更改/删除"
版本说明
  • TrueTable个人版:
    适合个人用户，分USB加密狗版、机器无关版、A版和C版,四者的功能是一样的，区别在于：
    • USB加密狗版:没有任何限制，使用时插上USB狗就可以

    • 机器无关版:可以在3台电脑上使用，一年后要重新激活(免费)

    • A版: 只能在1台电脑上使用；跟硬盘绑定，须有管理员的权限

    • C版: 只能在1台电脑上使用；跟网卡绑定，无权限要求

  • TrueTable企业版:
    适合企业用户，只需在一台计算机上注册，局域网内其它计算机均可使用，只要同时使用的用户数不超过"最大用户数"


 升级记录
TrueTable11.0:
全新的内核,速度更快,更稳定,界面更直观
表格更新功能全面升级,可以更新CAD中的任意表格,并支持自动分片
完善表格样式,使用更灵活,可设置首行高度
可直接导出、导入CSV文件
2种表格类型: 块参照，直线和文本
5种表格插入方式(表格四个角点以及指定窗口)均能动态提示
增强分片功能，可以设置表头，表尾
TrueTable10.1:
支持单元格边框，文字高度
完善了输出功能，定位更准确，支持天正7的表格
支持AutoCAD2007/2008/2009
提供简体中文，繁体中文，英文三个版本
修复了输出、更新模块中的一些bug

TrueTable10.0:
直接输出任意表格，包括：块参照，带属性的块参照，属性定义，
AutoCAD的Table实体，其它表格软件生成的表格
增加“配置”功能，可以在ACAD外部设置自动加载、执行命令
增加“文本替换”功能
完善表格样式管理
可以输出表格上面和下面的文字
自动过滤表格外面的空框
支持"Alt+数字键"的字符
修复了内存、图层、表头等一些bug
TrueTable9.9:
5种表格输入方式: 左上点，左下点，右上点，右下点，指定区域
优化的输出表格引擎，定位更准，兼容更多的表格
更完善的更新功能，可以按指定表格样式进行更新
更方便的表格样式管理，增加”自动“对齐方式，可以直接从AutoCAD和Excel中提取表格样式
增强的统计功能，支持复合过滤，还增加了批量替换功能
附带了更强劲的真实助手3.1：钢结构材料表制作的好帮手，自定义材料表，新增了变截面的功能，并可以从外部启动
修复了一些界面、内存方面的bug，程序运行更加稳定
TrueTable9.8:
运行速度全面提升，新增“快速输入模式”
优化更新模式，支持自动适配
完善上、下标，对齐功能
增加“行高固定”功能，保证各行都一样高
增加“文本格式”输出方式，
增加TrueTable工具条
TrueTable9.7:
更新模式支持上、下标
文字宽度自动匹配
智能的表格提取方式
完善了对自动换行，旋转文本的支持
可以更改关联表格信息
TrueTable9.6:
可以调整单元格上下左右边距
支持AutoCAD R2005
自动识别版本类别
中英文安装界面
TrueTable9.5:
输入表格时，可以指定表格线、文本的图层
采用高度精确算法，更适合输出图签
全程支持上、下标
全程支持竖向文本
全程支持MTEXT
可以选择是否绘制表格线
全新的TrueTable Assistant，更直观的材料表，独特的"Excel随意抓"技术
完善了表格高度计算，修正了文字垂直居中问题，修复了有隐藏行时的bug
TrueTable9.3:
准确控制表格尺寸，包括行高和列宽
从Excel中动态提取表格样式
输入Excel文件时，提供了表格选择功能
TrueTable9.2:
提供公式解释器，自由扩充材料公式
动态的材料列表，自动匹配所需材料
完善了合并单元格的处理
修复了MTEXT等几个bug，程序运行更稳定
TrueTable9.1:
动态编辑材料表
自动计算H型钢，C型钢
完善了文本解析引擎，使得与Word交互更方便
TrueTable9.0:
增加了生成材料表的功能
更新模式支持合并单元格，支持静态更新，不用打开Excel就能更新表格
支持polyline绘制的表格
增加了反安装功能
修复了表格超过500行不能正常输出的bug
修正了文字垂直居中的误差
提供表格样式设置，并可动态提取表格参数，导出、导入表格样式
支持隐藏单元格
TrueTable8.8:
输入、输出均支持合并单元格
表格列数无限制，并能显示Excel中的列号
更智能的参数设置，能够保存默认的设置
增加了安装程序，有自动加载功能
提供中英文两种界面
支持MTEXT
修正了表头计算的bug
TrueTable8.5:
输入支持合并单元格
支持更多的对齐方式：
水平：靠左，居中，靠右
垂直：靠上，居中，靠下
可以将多行设置为表头，表头可以包含合并单元格
双击表格外边框线，便可以打开相应的Excel文件
TrueTable8.0:
增加表格“更新模式”，只修改文本，而保持表格格式不变，表格不用再导来导去了
可以读取或更新Excel的选择区域
直接读取Excel单元格的对齐方式
增强记忆功能，能记住你每一次的操作
自动换行
TrueTable7.7:
对图形中的文本进行统计，并对统计结果提供三种排序方式，最后形成统计表
统计表可以输出到Excel，或者在直接在AoutoCAD中进行绘制
配备了灵活的文本过滤器，可以过滤数字及字母
支持一个单元格中有多行文本的表格，并兼容Excel中Alt+Enter的换行格式
TrueTable7.5:
动态输出到Excel，不必由文件中转
输入时，动态关联Excel，TrueTable会自动捕获已经打开的Excel
TrueTable7.0:
直接输出Excel文件
读入表格时，可以同时对多列参数进行修改
可以指定单元格的高度，也可以读取Excel中的单元格高度
提供参数设置，可以更改默认操作
TrueTable6.5:
直接读取Excel文件，无须转换成文本了
具有批处理功能，可以同时打开多个文件
TrueTable6.1:
提供了三种表格定位算法：自动，完整行，表格线，你总能找到一种适合你表格的方法
键入"truetable"，可以动态更改命令名
TrueTable6.0:
新增动态指定表格参数功能，可以指定各列的宽度，对齐方式，使你的表格更显完美
修正了一些BUG，程序运行更稳定
TrueTable5.5:
将任意表格在AutoCAD与Excel间导入导出
格式化输出文本文件，也可将外部文本文件导入AutoCAD，并建立表格


 最终用户许可协议

本《最终用户许可协议》（以下简称『协议』）是一份，您（个人或单一法人团体）与版权所有人，就TrueTable软件产品，其中包括书面资料、相关之媒体介质、以及可能包括『在线』或电子文档（以下简称为『软件产品』或『软件』）间所合法成立之协议。您一旦安装、拷贝或以其他方式使用本『软件产品』，即表示同意接受本『许可协议』条款之约束。若您不同意本『协议』之条款，即不得使用本『软件产品』。 本软件产品著作人、版权所有人为龚敏，并受着作权法、国际版权公约以及其它知识产权之法律及条约之保护，因此您不得复制本软件和附随之使用手册及其他书面资料，并不得利用任何方法取得、使用本软件之程序代码、文字资料、图片、影像、音乐和音效等电子文档。 本软件程序属于共享软件，您可以先试用，认为满意后再向版权所有人支付注册费。 您向作者支付注册费，从而获得本软件相应版本的最终使用许可权。

1．软件产品许可
安装、试用和使用： 您可安装无限制数量的本软件产品来试用。
您通过注册获得使用授权后，只能在一台计算机中安装和使用。当您需要在多台计算机中使用本软件时，必须购买相应数量的使用授权。除非得到版权所有人的明示授权许可，方可用于多用户环境或网络系统上。

复制、分发和传播： 您可以复制、分发和传播无限制数量的软件产品，但必须保证每一份复制、分发和传播都必须是完整和真实的，包括所有有关本软件产品的软件、电子文档、版权，亦包括本协议。 本软件可以独立分发亦可随同其他软件一起分发，但如因此而引起任何问题，版权所有人将不予承担任何责任。

2．版权
本软件产品（包括但不限于本软件产品中所含的任何图象、文字及本软件产品的任何副本）的一切所有权和知识产权，均由版权人拥有。通过使用本软件产品涉及及可访问的内容的一切所有权和知识产权均属于各自内容的所有者拥有并可能受适用著作权或其它知识产权法律和条约的保护。本《协议》不授予您使用这些内容的权利。

3．保证否认书
本软件版权人特此申明对本软件产品之使用不提供任何保证，不保证无错误、无故障产生，就衍生性损害不负赔偿责任；亦不对任何您使用此软件所遭遇到的任何理论上的或实际上的损失承担负责。因本软件的使用或性能所引起的全部风险完全由您承担。

4．其它权利和限制说明
禁止反向工程、反向编译和反向汇编： 您不得对本软件产品进行反向工程、反向编译和反向汇编。除非适用法律明文允许上述活动，否则您必须遵守此协议限制。

组件的分隔： 本软件产品是被当成一个单一产品而被授予许可使用，不得将各个部份分开用于任何目的行动。

终止： 如您未遵守本《协议》的各项条件，在不损害其它权利的情况下，版权人可将本《协议》终止。如发生此种情况，则您必须销毁“软件产品”及其各部分的所有副本。

软件的替换、修改和升级： 版权所有人保留在任何时候通过为您提供本软件的替换版本或修改版本或这类升级版本以替换、修改或使本软件升级的权利和为这类替换、修改或升级收取费用的权利。版权所有人提供给您的本软件的任何替换版本或修改软件代码或升级版本，将被视为本软件的一部分并且要受到本《协议》条款的制约（除非本《协议》被随附本软件的替换或修改版本或升级版本的另外一份《协议》取代）。如果提供本“软件”的一个替换或修改版本或任何升级版本，则您对本软件的继续使用条件是您接受本软件的这类替换或修改版本或升级版本以及任何随附的取代《协议》，并且就替换或修改版本的软件而言，您对本软件的所有先前版本的使用将被终止。

5. 个别授权
如有任何组织或个人利用本软件以任何方式为公众服务并同时满足其自身特定目的而分发、复制和传播本软件产品，均须得到版权人授权同意后方可进行，否则视为侵权。

版权所有 TrueTable.com
网 址: http://www.truetable.com
电子邮件: truetable@truetable.com


 输出到Excel

将CAD中的表格输出到Excel,可以直接输出CAD中的任意表格，支持:
  • 直线和文本组成的散开表格
  • 文本阵列(即没有表格线)
  • 块参照，带属性的块参照
  • AutoCAD自身的Table实体
  • 其它软件生成的表格

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"输出到Excel"
    〖命令〗tt_exp
  • 选择要输出的实体，如文本、直线、块参照等
  • 选择完毕，按鼠标右键或回车确定，
    TrueTable会将表格输出到Excel
技巧
  • 加快表格输出速度
    点击"设置"菜单，选择"表格"页面,
    勾选"字高固定"和"行高固定"，这样可以极大提高表格输出速度
  • 表格倒置
    有些CAD表格是按从下往上的顺序排列,即表头在下面，
    选择"表格倒置"后,输出到Excel,表格是从上往下排列的,即表头在上面,
    输入、输出和更新3个模块均支持表格倒置.
    使用方法:
    选择"TrueTable"菜单，点击"设置",选择"常规"页面,
    勾选"表格倒置"
  • 文本替换
    CAD有些特殊的字符表示方法,如"%%c"表示"φ",
    如果要在Excel中正确显示这些符号,就要用到文本替换.
    使用方法:
    选择"TrueTable"菜单，点击"设置",选择"文本替换"页面,
    选择"文本替换",然后设置需要转换的文本
  • 自动打断整行文本
    有些表格一行就是一个长字符串，如SFCAD生成的表格，
    要输出这种表格，就要用到"自动打断文本"功能
    使用方法:
    选择"TrueTable"菜单，点击"设置",选择"输出设置"页面,
    选择"自动打断文本",并指定断开的空格数


 输出到文件

将CAD中的表格输出到文本文件或者CSV文件,可以直接输出CAD中的任意表格，支持:
  • 直线和文本组成的散开表格
  • 文本阵列(即没有表格线)
  • 块参照，带属性的块参照
  • AutoCAD自身的Table实体
  • 其它软件生成的表格

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"输出到文件"
    〖命令〗tt_expfile
  • 选择要输出的实体，如文本、直线、块参照等
  • 选择完毕，在弹出的文件对话框中指输出定文件，表格便会输出到该文件中


 输入Excel表格

将Excel表格输入到CAD

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"输入Excel表格"
    〖命令〗tt_imp
  • 指定文字高度、宽度系数、行高等参数； 一般可以不做任何修改，全按默认的来
  • 点击"确定"按钮
  • 指定表格插入点,输入表格完成
技巧
  • 提高表格输入速度
    点击"设置"菜单，选择"表格"页面,
    勾选"字高固定"和"行高固定"，这样可以显著提高表格输入速度
  • 仅输入Excel选择区域
    选择"输入设置"页面，勾选"仅输入Excel选择区域"
  • 表格自动分片
    选择"表格分片"页面，勾选"自动分片"

    每片表格行数: 超过该行数，就另分一片
    表格间距: 每片表格间的水平距离
    表头行数: 指定每片表格的表头
    表尾行数: 指定每片表格的表尾
  • 指定表格颜色
    选择"输入设置"页面，点击颜色按钮或直接输入颜色号，
    可以分别设置表格外框线，网格线，文本颜色


 输入文件

将文本文件或者CSV文件输入到CAD

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"输入文件"
    〖命令〗tt_impfile
  • 在弹出的文件对话框中指定输入文件
  • 指定文本文件信息,一般可以不做任何修改，全按默认的来;
    自动分列: 根据分隔符号对文本进行分列
    不分列: 只有1列,即整行输入
  • 点击"确定"按钮
  • 指定表格插入点,输入文件完成


 更新表格

用Excel表格更新CAD中的表格，主要功能如下：
  • 可与当前打开的Excel表格更新
  • 可与Excel文件更新
  • 可与Excel表格的选择区域更新
  • 可更新CAD中的任意表格
  • 更新时支持自动分片

操作:
  • 先打开关联的Excel表格
  • 〖菜单〗选择"TrueTable"菜单，点击"更新"
    〖命令〗tt_update
  • 选择直线、文本、块参照实体，选择完毕，按鼠标右键或回车确定
  • 选择更新方式: 与当前打开的Excel表格更新 或者 与Excel文件更新
  • 点击"确定"按钮即可完成更新
说明
    更新后的表格将转换成TrueTable的表格实体(块参照),
    并自动记录相关联的Excel文件信息和分片信息.
技巧
  • 更新选择区域的表格
    选择"仅与Excel选择区域更新"


 表格样式

管理表格样式: 包括保存,删除,导入,提取等功能

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"表格样式"
    〖命令〗tt_style
说明
    表格样式包含了表格的一些基本设置，具体内容如下：
    • 标准文字信息: 包括文字的高度,宽度系数和文字样式
      "*当前*"表示使用CAD当前的文字样式
    • 行信息: 包括标准行高和首行高
      标准行高与Excel的标准行高对应,一般情况下行高都等于标准行高
      首行高为表格标题行高,"自动"表示跟随Excel中的首行高
    • 列信息:指定列信息
      "全部列"表示同时指定所有列信息,适合比较简单的情况
      "指定列"表示分别指定各列信息
      列信息包括:
      • 列宽: 各列宽度;"自动"表示跟随Excel的列宽或者自动计算
      • 水平对齐: 包括靠左,居中,靠右,自动;"自动"表示跟随Excel的对齐方式
      • 垂直对齐：包括靠下,中间,靠上,自动;"自动"表示跟随Excel的对齐方式
技巧
  • 从AutoCAD中提取表格样式
    点击样式名称右边的">>"按钮，在弹出的菜单中选择"<- CAD",然后选择CAD中的表格
    TrueTable可以从任意表格中提取样式，包括块参照，或者是其它软件生成的表格
  • 从Excel中提取表格样式
    点击样式名称右边的">>"按钮，在弹出的菜单中选择"<- Excel"
  • 导入以前版本的表格样式
    点击样式名称右边的">>"按钮，在弹出的菜单中选择"导入"
    可同时导入多个样式
  • 同时修改表格样式的多列属性
    按住"Ctrl"或"Shift"，选中多个项目，便可同时修改多列属性


 TrueTable命令一览表

命 令 | 功 能
tt | 显示命令提示行
tt_exp | 输出CAD中的表格到Excel
tt_expfile | 输出CAD中的表格到文件
tt_imp | 将Excel中的表格输入CAD
tt_impfile | 将文本文件(TXT)或CSV文件输入CAD
tt_upd | 更新CAD表格
tt_tools | TrueTable工具
tt_style | 表格样式
tt_config | 设置
tt_reg | 注册TrueTable
tt_help | 浏览TrueTable帮助文档
tt_about | 显示TrueTable版本信息


 批量输出

同时输出多片表格到Excel，即只要一次性框选所有表格，就会自动按片输出

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"工具"
    〖命令〗输入命令:tt_tools
  • 在工具主对话框选择"批量输出"
  • 框选所有要输出的表格
  • 选择完毕，按鼠标右键或回车确定，表格将自动按片输出到Excel


 统计文本

统计CAD中的文本: 对文本进行归并、排序 ，并将结果输出到Excel

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"工具"
    〖命令〗输入命令:tt_tools
  • 在工具主对话框选择"统计文本"
  • 在统计文本对话框中设置文本过滤和排序方式
    文本过滤: 包括关键字和图层过滤
    排序方式: 包括按字符和先按字符再按数字两中排序方式
  • 设置好后，按"确定"
  • 选择需要统计的文本
  • 选择完毕，按鼠标右键或回车确定，统计结果将输出到Excel


 输出材料表

直接输出MST，SFCAD，TWCAD生成的材料表，并对各材料表进行了特殊处理。
MST: 可一次性输出多片表格，自动处理表头；
SFCAD: 可一次性输出多片表格，自动分列，自动补全数据，自动处理表头；
TWCAD: 可一次性输出多片表格，自动补全数据，自动处理表头；

操作:
  • 〖菜单〗选择"TrueTable"菜单，点击"工具"
    〖命令〗输入命令:tt_tools
  • 在工具主对话框选择输出相应的材料表,按"确定"
  • 选择所有需要输出的材料表，可以同时选中多片
  • 选择完毕，按鼠标右键或回车确定，材料表输出到Excel


 注册TrueTable

TrueTable是共享软件，不注册也能使用大部分功能;
如果要使用全部功能，请购买注册，详见:
http://www.truetable.com/chs/buy

联系方式
联系电话: | 0512-66001687
网站: | www.truetable.com
TrueTable讨论(OICQ群): | 22061769
OICQ: | 21582110
MSN: | truetable@hotmail.com
Email: | truetable@truetable.com truetable@vip.163.com
 | 中国·苏州


 钢结构助手(TrueAssistant)

钢结构助手(TrueAssistant)是一款基于Excel的工具，能够自动计算材料的重量，提供了开放的材料库，并支持自定义材料表样式、公式扩展以及变截面材料

启动
    选择菜单 "开始" -> "程序" -> TrueTable菜单 -> "TrueAssistant"。

    或

    从TrueTable中启动:在AutoCAD中选择"TrueTable"菜单，点击"工具"，选中"新建材料表"，确定即可。
使用
    TrueAssistant启动后会自动打开一个材料表样本表格，或者关联一个已经打开的Excel表格；
    如果要重新关联Excel表格，点击"捕捉"按钮，按住鼠标左键不放，拖拽到欲关联的Excel表格上;
    如果成功关联到一个表格会显示绿灯，否则为红灯。
    成功关联Excel表格后，将输入焦点放到“规格”所在列，点击TrueAssistant列表中的材料，就会自动输入到Excel 中，并自动计算其重量；
    点击左边的材料索引，可以快速跳到对应的材料位置。如，选择"["，就可以快速跳到槽钢开始的位置；
    材料索引列表中红色部分为材料索引，蓝色部分为公式扩展材料，点击这些条目，便会把相应的材料前缀输入到Excel表格中；这些材料只要按规定输入，程序就会自动计算其重量； 默认包括钢板（"-"），钢管（"%%c"），H型钢（"H"），C型钢（"C"），钢筋("φ")，矩形截面("GX")，方管("FG")的重量程序自动计算，表示方法如下：
    • 钢板 : -300*20,-300X20,-300~500*20
    • 钢管 : D60*3.00,%%c76X3.5,%%c76*3.5
    • H型钢 : H300*200*6*8,H300X200X6X8,H300x200x6x8,H300~500*200*6*8
    • C型钢 : C120*60*20*3,C120X60X20X3,C120x60x20x3
    • 钢筋 : φ12
    • 矩形截面 : GX50*40
    • 方管 : FG50*40*2
    注意，有效输入区域为：“规 格”所在列，包括表头以下的部分；如果当前的输入焦点不在有效输入区域，那么点击材料表是没有反应的。
技巧
  • 计算变截面材料
      通过符号"~"可以定义变截面，甚至可以定义多重变截面；
      如变截面H型钢:H300~500X260X6X8,H300~500X200~400X6X8；
      如变截面钢筋:φ12~20 。
  • 自定义材料表样式
      程序提供了两种材料表样式:标准型，简单型，用户可在此基础上进行修改，方法如下:
      • 点击"设置"，选择"材料表样式"标签，选择要修改的样式，点击"编辑"；
      • 程序会打开相应的样式文件，修改完毕后，保存即可；
      • 注意，材料表样式数据要与Excel表格的内容对应起来:
          表头行数:材料表表头行数，只有在表头行数以下部分输入材料才会自动计算
          规格:规格所在列，只有在该列输入数据，才能自动计算
          长度:长度所在列
          数量:数量所在列，如果有两个数量，即"正面"、"反面"，以";"隔开
          重量:重量所在列，如果有两个重量，即"单重"、"总重"，以";"隔开
  • 扩充材料库
      点击"设置"，选择"常规"标签，点击“编辑”材料库文件；
      将数据添加到"用户自定义材料库"部分；
      材料表数据包括:规格,每米重(KG)。
  • 公式扩展
      用户可以自定义材料重量的计算公式，然后程序会根据公式自动计算重量，自定义材料会自动添加到索引列表中；
      如，定义方管公式 :
        表示方法: FGB*H*t , 前缀: FG , 公式: (B*H-(B-2*t)*(H-2*t))*7850/1E-6
      公式数据应放在"用户自定义公式"部分；
      自定义公式的有效符号:
      • 数字
      • 公式运算符 : "+", "-" , "*" , "/" , "^" , "SIN","COS","TAN","ASIN","ACOS","ATAN"
      • 括号 : "(" , ")"
      更详细的内容请看材料库文件:TTLib.txt


TrueTable 网络版

一.简介：
TrueTable网络版只需在一台计算机上注册，局域网内其它计算机上均可使用，只要同时使用的用户数不超过注册的"最大用户数"。

TrueTable网络版由两部分组成：TrueTable服务器端和TrueTable客户端。
服务器端安装在相对稳定的计算机上(推荐局域网的服务器)，负责管理客户端程序，并提供运行许可，必须注册后才可运行；
客户端安装在局域网内的计算机上，与TrueTable单机版功能一样，只是许可方式不一样，客户端运行时先会连接服务器端，只有得到服务器端许可后才能继续工作。

二.TrueTable服务器端：
  • 注册
    • TrueTable Server有2种注册方式:
    1. 使用USB加密狗，运行时将加密狗与电脑连接即可。
    2. 通过注册码注册。如果没有注册，程序启动时会弹出如下的注册窗口， 输入注册码即可。

  • 运行
    • TrueTable Server安装后，会自动运行，并在系统托盘上显示一个小图标 [image] ，主界面如下:

    点击"设置"可以指定IP地址和通讯端口。
    如果服务器上有多个网络，IP地址也有多个，请选择一个正确的局域网IP地址。
    三.TrueTable 客户端：
    首次运行TrueTable 客户端，需要进行网络设置。点击菜单"TrueTable"->"设置"，选择"网络"页面。

    TrueTable 客户端使用起来和TrueTable单机版一样，只需要将网络配置好。
    本地地址一般不用改，如果计算机处于多个网络之中，就需要选择一个正确的局域网IP地址，
    同服务器端设置。
    "服务器地址"和"服务器通讯端口"必须与服务器端一致。


简介

 真实表格(TrueTable)
真实表格(TrueTable)For AutoCAD是一款基于AutoCAD平台的软件，能够在AutoCAD和Excel间互导表格， 能输出、更新AutoCAD中的任意表格
  • 主要功能
    • 将CAD中的表格或文本输出到Excel
    • 将CAD中的表格或文本输出到文本文件(TXT)或CSV文件
    • 直接输出CAD中的任意表格，即使这些表格是复杂实体，
      比如：块参照，带属性的块参照，CAD自身的Table实体以及其它软件生成的表格
    • 将Excel表格导入CAD
    • 将文本文件(TXT)或CSV文件导入CAD
    • 同时将多个CAD表格输出到Excel文件
    • 可更新CAD中的任意表格，
      数据源可以是打开的Excel表格或Excel文件
    • 支持文本替换，可以对特殊字符进行转换
    • 可以精确定义CAD表格尺寸，
      包括文字高度、文字宽度系数、行高、列宽
    • 表格自动分片，并能设置各片表格的表头，表尾
    • 支持文本水平、垂直排列，共9种对齐方式
    • 支持自动换行，上、下标，文本旋转，竖直文本，多行文本
    • 具有文本自动替换功能，能使CAD中的特殊符号在Excel中正确显示，如将"%%c"替换为"Φ"
    • 支持Excel的隐藏行、列
    • 支持表格倒置，即输出、输入表格时颠倒表格顺序
    • 5种表格插入方式: 表格四个角点以及指定窗口
    • 对CAD中的文本进行统计
    • 材料表自动计算,钢结构用钢量统计
  • 系统要求
    • AutoCAD 14/2000/2002/2004/2005/2006/2007/2008/2009
    • Excel 97 及其以后版本
  • 联系方式
    联系电话: 0512-66001687
    网站: www.truetable.com
    TrueTable讨论(OICQ群): 22061769
    OICQ: 21582110
    MSN: truetable@hotmail.com
    Email: truetable@truetable.com truetable@vip.163.com
    中国·苏州